• You will get a free Netflix membership when you posts 30 threads!

LG LG OLED no audio over ARC when using HDMI ARC connection.

Wyatt21

Member
New LG OLED C7 with HDMI ArC connected to Marantz AVR about 5 years old. AVR can handle DD+/TrueHD but not Atmos. Marantz is hub. TV Sound set to HDMI ArC with Simplink on and digital sound to auto. On AVR HDMI control is on. AVR recognizes DD+ signal from TV l, and all I get is clicky staticy noise. No audio from content. If I am just viewing Netflix landing page with stereo I get audio. If I change TV audio to PCM output l, I get stereo audio but can’t get DD+/5.1 Audio when watching the Crown for example. Just replaced HDMI cables thinking that could be issue and no luck. Reset TV to factory settings and no luck.
 

akagi1945

Member
LG responded :

"In response to your inquiry, according to the product support page of the OLED65B7P TV, a software version (Ver. 04.70.36) has been released to improve the Dolby no audio symptom exhibited by the unit when using HDMI ARC connection."
 

Wyatt21

Member
Fixed!

I tried working around this problem with optical. It works but lost my HDMI CEC function as I had to unplug the HDMI cable to get the optical signal to work. Apparently the ARC is the problem.
That being said, I decided to try the Amazon Basics cable 10’ for $8. I have been using a high speed 4K Monoprice cable which worked fine until a few days ago. Anyhow, the new cable is working fine. Giving me back full ARC functionality. Amazing! Found this fix in another thread.
 
Top