Samsung Windows 10 HDR doesn't work on Samsung 8K QLED Q900R


Spent the entire weekend messing with a 75 Q900R 8K TV for my gaming/rendering/HTPC rig trying to get HDR working on Windows 10. The PC is equipped with dual 2080 Ti's bridged with NVlink. Managed to get 4K@60hz working, but it looks like crap. Everything is washed out. Even removed one of the 2080 TI's and put it into an older i7 5930k gaming rig to see if it makes a difference.

Would appreciate some advice on this. Can I assume Windows HDR doesn't work for 4K@120 and 8K@30?

I'm coming from a 65" C8 OLED and got the Samsung after seeing early stages of burn in. Got the Q900R for the same price as the Q90, but looks like I'm going to pack it up and return it.


You don't write what settings you are using but here is a good starting point Samsung Q900/Q900R 8k QLED Calibration Settings Are you using HDMI port 4?


HDR is automatically enabled for the native apps. When you start playing HDR content, a small HDR icon appears next to the picture mode on the quick settings menu. Once you start playing HDR content, some of the settings change automatically, including the Backlight, which increases to 'Max.' We recommend leaving these settings to their default settings in HDR.

Samsung Q900/Q900R 8k QLED Calibration Settings 89
Samsung Q900/Q900R 8k QLED Calibration Settings 57

For HDR to work from external devices, Input Signal Plus usually has to be enabled from the External Device Manager menu for the input you are using. Older devices may have compatibility issues if this option is left enabled, so it is recommended to only enable this setting for devices that require it.

If you find HDR content too dim, increase the Brightness, and set Contrast Enhancer to 'High.' A Brightness setting of '5' and Contrast Enhancer set to 'High' produces a noticeably brighter picture in HDR.