• You will get a free Netflix membership when you posts 30 threads!

Hisense Hisense TV get stuck after 3-4 minutes loading Youtube

I have a Hisense Smart TV I bought a month ago. It started to load on youtube after a week, we decided to return it but by next week it was fine, now after a month when Walmart wouldn't probably take it back nomore, it started disturbing again.
Wheneve I go to youtube and start a video after 3-4 minutes it will get stuck on loading and thats it now it wouldn't resume no matter what buttons I press, sometimes it might resume back just for the same thing to happen again 2 minutes later, and other times it will be stuck there for an eternity.

Any tips how to fix this? Or am I the only one here with a problem like this. I tried resetting the tv, use youtube through chromecast, but no help.
 

akagi1945

Member
I have a Hisense Smart TV I bought a month ago. It started to load on youtube after a week, we decided to return it but by next week it was fine, now after a month when Walmart wouldn't probably take it back nomore, it started disturbing again.
Wheneve I go to youtube and start a video after 3-4 minutes it will get stuck on loading and thats it now it wouldn't resume no matter what buttons I press, sometimes it might resume back just for the same thing to happen again 2 minutes later, and other times it will be stuck there for an eternity.

Any tips how to fix this? Or am I the only one here with a problem like this. I tried resetting the tv, use youtube through chromecast, but no help.
That points to non-TV issues. Chromecast Youtube should be better than the TV version but the fact that Youtube fails on the Chromecast means it's either Google (they own YouTube) problems or your internet provider or connection.

For a test, try using the Google DNS of 8.8.8.8. How is on the the web and my favorite is to set the router to hand out this instead of 192.x.x.x or the ISP DNS.
 
Top